vue.js是否支持ie8?

Vue.js 不支持 IE8 及其以下版本,因为 Vue.js 使用了 IE8 不能模拟的 ECMAScript 5 特性。 Vue.js 支持所有兼容 ECMAScript 5 的浏览器。

先来看下Vue为什么不能兼容IE8

根源:ie8及以下版本不支持Object.defineProperty方法,但这个是vue实现响应式的所必须的,所以从Vue的源码来看根本就无法支持IE8;

再者来说,Vue也需要支持Promise的支持,IE8同样不支持Promsie;

在从Vue官网上看下为什么不支持IE8

Vue.js会对所有的实现双向绑定的数据,使用 Object.defineProperty 把这些属性全部转为 getter/setter。Object.defineProperty 是 ES5 中一个无法 shim 的特性,这也就是为什么 Vue 不支持 IE8 以及更低版本浏览器的原因。

注意这里:Object.defineProperty是无法通过垫板实现的一个方法,是和浏览器自身有关系的,所以Vue从根本上来说本来就无法支持IE8;

Vue 不支持 IE8 及以下版本,因为 Vue 使用了 IE8 无法模拟的 ECMAScript 5 特性。但它支持所有兼容 ECMAScript 5 的浏览器

更多web前端开发知识,请查阅 HTML中文网 !!

以上就是vue.js是否支持ie8?的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » Vue.js 答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏