npm install安装报错怎么解决?

npm install 安装报错解决办法

报错——operation not permitted(没有许可证)

【原因】npm的版本过高,导致一些依赖包下载不全

【解决】npm install 后面增加--no-optional

npm i xxx --no-optional

报错——Missing: chromedriver

【解决】安装 chromedriver 即可

npm install chromedriver --chromedriver_cdnurl=http://cdn.npm.taobao.org/dist/chromedriver

报其他错误

1、删除npmrc文件

【注意】不是nodejs安装目录npm模块下的那个npmrc文件,而是在C:\Users{账户}\下的.npmrc文件

2、直接用命令清理

控制台输入:

npm cache clean --force

降低npm版本

npm i -g npm@6.0.1

想要了解更多相关知识,可访问 前端学习网站!!

以上就是npm install安装报错怎么解决?的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » Node.js答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏