jqModal is trying to run my whole page!

I just started experimenting with jqModal and am having a strange issue. The modal window is displayed correctly however I get a javascript error when I click anywhere inside it. When I look at the offending line of code, it turns out that jqModal is trying to run my entire page as if it were one big piece of javascript. Since I wrote this post, I discovered that the code works fine in FireFox. The issue is IE of course. My markup: Save this search Modal window markup: Close Clicking on the “Save this search” link correctly displays the modal window. Clicking anywhere in the modal, causes this error: > Line: 5 Error: Object doesn't support > this property or method When I look at the code it’s trying to execute, it turns out to be my whole page which of course triggers an error: ![alt text][1] I have no clue what would cause this behavior. If I continue past the error, the window works correctly and my action method gets called when I click Save. Help! Thanks! Rick [1]: http://i.stack.imgur.com/rV3nn.jpg [2]: http://i.stack.imgur.com/huvLb.png [3]: http://i.stack.imgur.com/DTjeV.png [4]: http://i.stack.imgur.com/swR4n.png
Strange error. I've used jqModal and cannot recognize the error on IE8, you are describing above. Can you put up a simple test page?

以上就是jqModal is trying to run my whole page!的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » jQuery 答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏