ie8 jquery支不支持?

ie8 jquery支不支持?

jQuery1.x版本是支持ie8的;但jQuery 2.x版本和3.x版本不支持ie8。

Jquery从2.0版本开始不再进行IE低版本(IE6、IE7、IE8)的兼容性处理,最后支持IE8的版本是1.9。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jquery1.x版本。

维护ie678是意见头疼的事情,一般我们都会额外加载一个css和js单独处理。值得庆幸的是使用这些浏览器的人也逐步减少,电脑端用户已经逐步被移动端用户所取代,如果没有特殊要求的话,一般都会选择放弃对ie678的支持。

IE8不支持jQuery版本解决办法

思路是通过判断IE浏览器的版本来加载对应版本的jquery。

使用

<!--[if IE 8]> 仅IE8可识别 <![endif]-->

可以判断IE浏览器版本是不是8

最终代码:

  <!--[if !IE]> -->
        <script src="/Scripts/jquery-2.0.2.min.js"></script>
    <!-- <![endif]-->


    <!--[if lte IE 8]>
         <script src="/Scripts/jquery-1.11.1.min.js"></script>
    <![endif]-->
   
     <!--[if gt IE 8]>
         <script src="/Scripts/jquery-2.0.2.min.js"></script>
    <![endif]-->

解释一下:

不是IE就用2.02,IE8以上也用2.0.2,IE8及以下用1.11版本

更多web前端学习知识,请查阅 HTML中文网 !!

以上就是ie8 jquery支不支持?的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » jQuery 答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏