jquery不兼容怎么办

JQuery是一个特别强大的javascript代码库,,它的操作DOM的能力是相当强大的,JQuery可以说是支持各大主流浏览器,但是随着时代的不断发展,浏览器是在不断的更新变换的,浏览器界的前带头大哥IE,其影响力还是稍微有那么一点点的。虽然最终还是屈服了,但是还是有那么一群IE6、7、8的老用户,为了满足各种用户的需求,JQuery可以说是做的非常好的。

其实JQuery也是在不断的发展,更新版本的,在JQuery的2.0版本以前还是在考虑着这些IE6、7、8的老用户们,时时刻刻在兼容着它们。可能随着时代的不断发展变化,觉得这些IE6、7、8的老用户越来越少了,在2.0版本开始,就不再支持IE6、7、8浏览器了。

jquery不兼容怎么办?

兼容的方式来导入JQuery文件

在网页制作过程中,为了达到更好的兼容性,可以通过条件注释的方法,来导入JQuery文件

具体的代码如下:

<body>
    <p id="p">p标签</p>
</body>
<!--[if lt IE 9]>
        <script src="js/jquery-1.10.2.js"></script>
<![endif]-->
<!--[if gte IE 9]><!-->
        <script src="js/jquery-3.1.1.js"></script>
<!--<![endif]-->
<script type="text/javascript">
    $("#p").css("color","red");
</script>

  所显示的结果如下图:

  无论IE多少版本,都会支持,字体的颜色也都变为红色。

  

7f0accd7008a3f096fdc9789ec8c092.png

更多jquery的相关知识,可访问:web前端自学!!

以上就是jquery不兼容怎么办的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » jQuery 答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏