easyui和bootstrap冲突吗?

easyui和bootstrap部分css类有冲突。那么如何解决bootstrap和easyUI部分css类冲突问题?下面本篇文章给大家介绍一下。有一定的参考价值,有需要的朋友可以参考一下,希望对大家有所帮助。

在使用bootstrap和easyui的时候,发现很多有冲突的地方,包括datagrid控件和combo等,以下进行的问题修正,保证easyui正常显示

原理就是还原easyui中的默认设置,让bootstrap的作用域不在easyui控件定义的css范围内。

/*bootstrap兼容问题和easyui的bug*/
.panel-header, .panel-body {
border-width: 0px;
}
.datagrid,.combo-p{
border:solid 1px #D4D4D4;
}
.datagrid *{
-webkit-box-sizing: content-box;
-moz-box-sizing: content-box;
box-sizing: content-box;
}

更多web前端开发知识,请查阅 HTML中文网 !!

以上就是easyui和bootstrap冲突吗?的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » jQuery 答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏