jquery从哪个版本开始不兼容ie8?

jQuery 是一个简洁而快速的 JavaScript 库,可用于简化事件处理,HTML 文档遍历,Ajax 交互和动画,以便快速开发网站。jQuery 简化了 HTML 的客户端脚本,从而简化了 Web 2.0 应用程序的开发。

jQuery设计的宗旨是“write Less,Do More”,即倡导写更少的代码,做更多的事情。它封装JavaScript常用的功能代码,提供一种简便的JavaScript设计模式,优化HTML文档操作、事件处理、动画设计和Ajax交互。

【相关教程推荐:jQuery视频教程

jquery从哪个版本开始不兼容ie8?

Jquery从2.0版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jquery1.x版本。

一般的处理方式是给网页写两套或者多套JS代码以适应不同版本、不同类型的浏览器,然后使用原生JS判断浏览器的型号和版本来加载不同的JS文件,具体的实现方法如下:

<script language="javascript"> 
//判断是否为IE浏览器
if(navigator.appName == "Microsoft Internet Explorer") 
{ 
   if(navigator.appVersion.match(/7./i) == '6.' ||
       navigator.appVersion.match(/7./i) == '7.' ||
       navigator.appVersion.match(/7./i) == '8.') 
   { 
      document.write("<script src=\"myjs1.js\">"+"</script>"); 
   }else{     
      document.write("<script src=\"myjs2.js.js\">"+"</script>"); 
   } 
} 
</script>

更多web前端课程相关知识,请查阅 HTML中文网 !!

以上就是jquery从哪个版本开始不兼容ie8?的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » jQuery 答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏