如何选择jquery版本?

如何选择适合项目的jquery版本?下面本篇文章给大家分析一下,为大家推荐一下jQuery的版本。有一定的参考价值,有需要的朋友可以参考一下,希望对大家有所帮助。

电脑端 推荐选择 jQuery 1.9 版本,理由如下:

  • 兼容IE8,在当下电脑端兼容IE8还是有需要的(管理系统除外)。

  • API与更高版本基本一致,又将低版本的不足之处进行了修复,比如:选择器的性能、方法名的不规范等等

  • 在1.9版本中有jQuery1.7中引进的事件处理函数界的一哥 “.on()”函数。

【如果你想了解更多关于JavaScript、jQuery的知识,可以点击:js学习网站

移动端 推荐选择 jQuery 3.x 版本,理由如下:

  • 新的肯定更好啊,不好还需要更新吗?这里不需要理由。

不推荐使用的 jQuery 版本:

  • 低于 jQuery 1.7 的版本:

    1、与现在的高版本API相差比较大;

    2、选择器等各方面性能不高。

  • 2.x 版本:

    1、存在的周期短(2.0.0版本开始 至 2.2.4结束);

    2、不如1.9版本能兼容IE8;

    3、现如今 3.x也早以发布再使用 2.x 版本意义 不大。

更多web开发知识,请查阅 HTML中文网 !!

以上就是如何选择jquery版本?的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » jQuery 答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏