How to install Hibernate in eclipse

I followed this [step by step guide for installing Hibernate][1] After selecting all the things that is mentioned in the site. I clicked next so eclipse was calculating something (Calculating requirements and dependencies) then I got this error saying that **The operation cannot be completed. See the details.** Cannot complete the install because of a conflicting dependency. Software being installed: Hibernate Tools 3.4.0.v20110729-2006-H171-Final (org.hibernate.eclipse.feature.feature.group 3.4.0.v20110729-2006-H171-Final) Software currently installed: Eclipse IDE for Java EE Developers 1.4.1.20110909-1818 (epp.package.jee 1.4.1.20110909-1818) Only one of the following can be installed at once: Apache Ant 1.8.2.v20110505-1300 (org.apache.ant 1.8.2.v20110505-1300) Apache Ant 1.7.0.v20100518-1140 (org.apache.ant 1.7.0.v20100518-1140) Only one of the following can be installed at once: Java Development Tools Core 3.7.0.v_B61 (org.eclipse.jdt.core 3.7.0.v_B61) Java Development Tools Core 3.7.1.v_B76_R37x (org.eclipse.jdt.core 3.7.1.v_B76_R37x) Object Teams Development Tooling Core 3.7.0.v_OTDT_r200_201106070730 (org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730) Java Development Tools Core 3.6.0.v_A58 (org.eclipse.jdt.core 3.6.0.v_A58) Object Teams Development Tooling Core 3.7.1.v_OTDT_r201_201109101025 (org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025) Java Development Tools Core 3.6.2.v_A76_R36x (org.eclipse.jdt.core 3.6.2.v_A76_R36x) Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x) Only one of the following can be installed at once: Structured Source Editor 1.3.1.v201108191312 (org.eclipse.wst.sse.ui 1.3.1.v201108191312) Structured Source Editor 1.2.5.v201108191505 (org.eclipse.wst.sse.ui 1.2.5.v201108191505) Structured Source Editor 1.3.0.v201105101529 (org.eclipse.wst.sse.ui 1.3.0.v201105101529) Structured Source Editor 1.2.3.v201102102045 (org.eclipse.wst.sse.ui 1.2.3.v201102102045) Cannot satisfy dependency: From: Eclipse IDE for Java EE Developers 1.4.1.20110909-1818 (epp.package.jee 1.4.1.20110909-1818) To: org.eclipse.epp.package.jee.feature.feature.group [1.4.1.20110909-1818] Cannot satisfy dependency: From: Java EE IDE Feature 1.4.1.20110909-1818 (org.eclipse.epp.package.jee.feature.feature.group 1.4.1.20110909-1818) To: org.eclipse.jdt.feature.group 0.0.0 Cannot satisfy dependency: From: Java EE IDE Feature 1.4.1.20110909-1818 (org.eclipse.epp.package.jee.feature.feature.group 1.4.1.20110909-1818) To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0 Cannot satisfy dependency: From: Java EE IDE Feature 1.4.1.20110909-1818 (org.eclipse.epp.package.jee.feature.feature.group 1.4.1.20110909-1818) To: org.eclipse.platform.feature.group [3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK] Cannot satisfy dependency: From: Java Annotation Processing Core 3.3.400.v20100513-0845 (org.eclipse.jdt.apt.core 3.3.400.v20100513-0845) To: bundle org.apache.ant [1.6.5,1.8.0) Cannot satisfy dependency: From: Java Annotation Processing Core 3.3.401.R36_v20100727-0110 (org.eclipse.jdt.apt.core 3.3.401.R36_v20100727-0110) To: bundle org.apache.ant [1.6.5,1.8.0) Cannot satisfy dependency: From: Java Annotation Processing Core 3.3.402.R36_v20110120-1000 (org.eclipse.jdt.apt.core 3.3.402.R36_v20110120-1000) To: bundle org.apache.ant [1.6.5,1.8.0) Cannot satisfy dependency: From: Eclipse Java Development Tools 3.6.0.v20100526-0800-7z8XFUJFMTfCWGoVuHImpms9H155 (org.eclipse.jdt.feature.group 3.6.0.v20100526-0800-7z8XFUJFMTfCWGoVuHImpms9H155) To: org.eclipse.jdt.apt.core [3.3.400.v20100513-0845] Cannot satisfy dependency: From: Eclipse Java Development Tools 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH (org.eclipse.jdt.feature.group 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH) To: org.eclipse.jdt.apt.core [3.3.401.R36_v20100727-0110] Cannot satisfy dependency: From: Eclipse Java Development Tools 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F (org.eclipse.jdt.feature.group 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F) To: org.eclipse.jdt.apt.core [3.3.402.R36_v20110120-1000] Cannot satisfy dependency: From: Eclipse Java Development Tools 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B (org.eclipse.jdt.feature.group 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B) To: org.eclipse.jdt.core [3.7.0.v_B61] Cannot satisfy dependency: From: Eclipse Java Development Tools 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK (org.eclipse.jdt.feature.group 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK) To: org.eclipse.jdt.core [3.7.1.v_B76_R37x] Cannot satisfy dependency: From: Dali Java Persistence Tools - UI 2.3.2.v201008252310 (org.eclipse.jpt.ui 2.3.2.v201008252310) To: bundle org.eclipse.wst.sse.ui [1.1.0,1.3.0) Cannot satisfy dependency: From: Structured Source JSP Model 1.2.304.v201102160550 (org.eclipse.jst.jsp.core 1.2.304.v201102160550) To: bundle org.eclipse.jdt.core [3.5.0,3.7.0) Cannot satisfy dependency: From: Structured Source JSP Model 1.2.308.v201108241905 (org.eclipse.jst.jsp.core 1.2.308.v201108241905) To: bundle org.eclipse.jdt.core [3.5.0,3.7.0) Cannot satisfy dependency: From: JST Web Core 3.2.3.v201102101900-7Q7BG7HFE9Le9HDKz-hZ-Rlojqz- (org.eclipse.jst.web_core.feature.feature.group 3.2.3.v201102101900-7Q7BG7HFE9Le9HDKz-hZ-Rlojqz-) To: org.eclipse.jst.jsp.core [1.2.304.v201102160550] Cannot satisfy dependency: From: JST Web Core 3.2.5.v201106160200-7Q7BG7XFE9LeABBt3_bz0Jqpiwz018nIng5963 (org.eclipse.jst.web_core.feature.feature.group 3.2.5.v201106160200-7Q7BG7XFE9LeABBt3_bz0Jqpiwz018nIng5963) To: org.eclipse.jst.jsp.core [1.2.308.v201108241905] Cannot satisfy dependency: From: JST Web UI 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ (org.eclipse.jst.web_ui.feature.feature.group 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ) To: org.eclipse.jst.web_core.feature.feature.group [3.2.3.v201102101900-7Q7BG7HFE9Le9HDKz-hZ-Rlojqz-] Cannot satisfy dependency: From: JST Web UI 3.2.5.v201106160200-7F77FJfC25Tkfz-UplgtV0qd47wahfl47v01Hy6N (org.eclipse.jst.web_ui.feature.feature.group 3.2.5.v201106160200-7F77FJfC25Tkfz-UplgtV0qd47wahfl47v01Hy6N) To: org.eclipse.jst.web_core.feature.feature.group [3.2.5.v201106160200-7Q7BG7XFE9LeABBt3_bz0Jqpiwz018nIng5963] Cannot satisfy dependency: From: Eclipse Java Web Developer Tools 3.3.0.v201103310009-7F7AFO-C25TohFunnht_0yz0s92kZCb4ufuz0TLG (org.eclipse.jst.web_ui.feature.feature.group 3.3.0.v201103310009-7F7AFO-C25TohFunnht_0yz0s92kZCb4ufuz0TLG) To: org.eclipse.wst.jsdt.web.support.jsp [1.0.400.v201102241833] Cannot satisfy dependency: From: Eclipse Java Web Developer Tools 3.3.1.v201108102009-7F7AFO3C25TohHcojh0Zyz-B7FyifIcGz-xuz-_W (org.eclipse.jst.web_ui.feature.feature.group 3.3.1.v201108102009-7F7AFO3C25TohHcojh0Zyz-B7FyifIcGz-xuz-_W) To: org.eclipse.wst.jsdt.web.support.jsp [1.0.400.v201102241833] Cannot satisfy dependency: From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK) To: org.apache.ant [1.8.2.v20110505-1300] Cannot satisfy dependency: From: JSDT support for JSP Plug-in 1.0.400.v201102241833 (org.eclipse.wst.jsdt.web.support.jsp 1.0.400.v201102241833) To: bundle org.eclipse.wst.sse.ui [1.3.0,1.4.0) Cannot satisfy dependency: From: Hibernate Tools 3.4.0.v20110729-2006-H171-Final (org.hibernate.eclipse.feature.feature.group 3.4.0.v20110729-2006-H171-Final) To: org.jboss.tools.hibernate.jpt.ui [3.4.1.v20110729-2006-H171-Final] Cannot satisfy dependency: From: Hibernate Jdt UI 3.4.1.v20110729-2006-H171-Final (org.jboss.tools.hibernate.jpt.ui 3.4.1.v20110729-2006-H171-Final) To: bundle org.eclipse.jpt.ui 0.0.0 Any suggestions to overcome this error? It is happening because of the version of the eclipse(eclipse indigo) software I have installed and it is conflicting with hibernate version? [1]: http://www.mkyong.com/hibernate/how-to-install-hibernate-tools-in-eclipse-ide/

以上就是How to install Hibernate in eclipse的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » JavaScript 答疑

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏