layui支不支持ie?是否兼容ie8?

layui(谐音:类UI) 是一款采用自身模块规范编写的前端 UI 框架,遵循原生 HTML/CSS/JS 的书写与组织形式,门槛极低,拿来即用。其外在极简,却又不失饱满的内在,体积轻盈,组件丰盈,从核心代码到 API 的每一处细节都经过精心雕琢,非常适合界面的快速开发。layui 首个版本发布于2016年金秋,她区别于那些基于 MVVM 底层的 UI 框架,却并非逆道而行,而是信奉返璞归真之道。

准确地说,她更多是为服务端程序员量身定做,你无需涉足各种前端工具的复杂配置,只需面对浏览器本身,让一切你所需要的元素与交互,从这里信手拈来。

layui支不支持ie?是否兼容ie8?

layui支持除了IE6/7的其他ie浏览器,是兼容ie8的。

准确来说layui兼容人类正在使用的全部浏览器(IE6/7除外),可作为 PC 端后台系统与前台界面的速成开发方案。

layui兼容ie8中出现的问题

1、检查jquery版本

假如项目中有用到jquery,则首先检查jquery版本是否在2.0以上.2.0以上版本的jquery不支持ie8.

2、出现对象不支持此属性或方法

1.png

假如出现此问题,可能是因为动态赋值<select>的时候,没有加<option>的原因

2.png

加上<option>以后,问题解决.

3.png

4.png

更多web前端知识,请查阅 HTML中文网 !!

以上就是layui支不支持ie?是否兼容ie8?的详细内容,更多请关注web前端其它相关文章!

赞(0) 打赏
未经允许不得转载:web前端首页 » Layui 教程

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

前端开发相关广告投放 更专业 更精准

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏